Choosing the right .NET version for your exchange environment

Before you install Exchange 2016, you need to review the topic to ensure that your network, hardware, software, clients, and other elements meet the requirements for Exchange 2016. In addition, make sure you understand the coexistence scenarios that are supported for Exchange 2016 and earlier versions of Exchange.

 

There are different scenarios of supported coexistence.

Here in the list below, you can see, which scenarios are still supported:

Exchange versionExchange organization coexistence
Exchange 2007 and earlier versionsNot supported
Exchange 2010Supported with Update Rollup 11 for Exchange 2010 SP3 or later on all Exchange 2010 servers in the organization, including Edge Transport servers.
Exchange 2013Supported with Exchange 2013 Cumulative Update 10 or later on all Exchange 2013 servers in the organization, including Edge Transport servers.
Mixed Exchange 2010 and Exchange 2013 organizationSupported with the following minimum versions of Exchange:

  • Update Rollup 11 Exchange 2010 SP3 or later on all Exchange 2010 servers in the organization, including Edge Transport servers.
  • Exchange 2013 Cumulative Update 10 or later on all Exchange 2013 servers in the organization, including Edge Transport servers.

 

.NET Framework for Exchange server 2016

In old Exchange server versions we were able to run the .NET framework 4.5.2 for a log time. Even in the RTM and CU1 version of the Exchange server 2016. Since then Microsoft has made some changes. You can see in the list below which version of .NET is supported for which version of Exchange server 2016.

Exchange version.NET Framework 4.7.1.NET Framework 4.6.2.NET Framework 4.6.1.NET Framework 4.5.2
Exchange 2016 CU8

X

X

 

 
Exchange 2016 CU5 – CU7 X 

 

Exchange 2016 CU4 XX3

X3

Exchange 2016 CU3 XX

X

Exchange 2016 CU2  

X1,2

X

Exchange 2016 RTM or CU1  

 

X

1 .NET Framework 4.6.1 requires post-release fixes if you want to install it on a server running Exchange 2016 CU2. For more information. see Exchange 2016 prerequisites.

2 If you’re upgrading to Exchange 2016 CU4 from Exchange 2016 RTM, CU1, or CU2, we strongly recommend that you install Exchange 2016 CU4 before .NET Framework 4.6.2 or .NET Framework 4.6.1 and its related post-release fixes.

3Starting with Exchange 2016 CU5, .NET Framework 4.6.1 and 4.5.2 will no longer be supported with Exchange 2016. While those versions of .NET Framework are supported by Exchange 2016 CU4, we strongly recommend that you upgrade servers running Exchange 2016 to .NET Framework 4.6.2.

 

 

 

Photo by Sharon McCutcheon on Unsplash


Leave a Reply

Your email address will not be published. Required fields are marked *